The issues affecting Connect have been fully resolved. Users should now be able to log in and access orders, tasks, documents, and messages without further disruptions. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted Dec 17, 2025 - 07:01 PST
Identified
The issue affecting Connect has been identified. Our engineering team is currently rolling out a fix to restore full service functionality. We anticipate that access to orders, documents, and messages will be restored shortly. We will continue to monitor the situation and provide confirmation once the update is complete.
Posted Dec 17, 2025 - 06:54 PST
Investigating
We are currently investigating a service degradation within Connect. Users are experiencing errors when attempting to access orders, which is impacting the ability to open tasks, view documents, or access messages. This issue affects access via both direct login and email links. Our team is actively working to resolve this issue.